Login to Members Area

Choose the service you want to log in
     
24x7x365 Presence
1-888-289-2246
Live Chat

Hosting Blog

 

How to fix the error: "Please reinstall the libcurl"

While compiling PHP with cURL support we get the error below:-

==========================================================================
checking for cURL support... yes
checking if we should use cURL for URL streams... yes
checking for cURL in the default path... not found
configure: error: Please reinstall the libcurl distribution -
    easy.h should be in <curl-dir>/include/curl/
==========================================================================

However, if we check libcurl is already installed on the server with the command below:-

yum list|grep curl

curl.x86_64                              7.19.7-37.el6_4                @updates
libcurl.x86_64                           7.19.7-37.el6_4                @updates
libcurl-devel.x86_64                     7.19.7-37.el6_4                @updates
python-pycurl.x86_64                     7.19.0-8.el6                   @anaconda-CentOS-201207061011.x86_64/6.3
libcurl.i686                             7.19.7-37.el6_4                updates
libcurl-devel.i686                       7.19.7-37.el6_4                updates

In this we have to make sure that the libcurl-devel package is installed on the server, if it is not then install it first as below:-

yum install libcurl-devel -y

and then try to re-compile PHP with cURL and it should be able to compile this time.

Sachin Tuesday 22 October 2013 - 07:10 am | | Default
Used tags: , , , , ,

two comments

One or more comments are waiting for approval by an editor.

(optional field)
(optional field)

Comment moderation is enabled on this site. This means that your comment will not be visible until it has been approved by an editor.

Remember personal info?
Small print: All html tags except <b> and <i> will be removed from your comment. You can make links by just typing the url or mail-address.